Go to bottom

C64 troubleshooting

category: general [glöplog]
Dusted off the old c64 today, and remembered a problem it always used to have. Basically when it's started up it will slowly fill the screen with garbage, among some intermittent "device not ready" errors when accessing the 1541uii. After awhile (10-20mins or so) it works normally with the very occasional crash during a demo.

My instinct screams "PLA" but it's a bit odd that it gets _better_ as the machine runs longer? Isn't the PLA supposed to get _worse_ over time?
added on the 2016-11-16 22:19:40 by ferris ferris
maybe the guys outside the Matrix are trying to contact you!
added on the 2016-11-16 22:32:13 by farfar farfar
http://personalpages.tds.net/~rcarlsen/cbm/c64/c64-ic.txt is always a good place to start checking, as well as Ray Carlsen's other resources.
added on the 2016-11-16 23:30:51 by Radiant Radiant
I would suggest checking the power supply first, they are notoriously bad on the +5 Vdc line and can generate all sorts of weird behaviour (as well as thrash the machine).
added on the 2016-11-16 23:36:15 by Radiant Radiant
haven't tested with a multimeter, but I've tested with two psu's, both show the same behavior
added on the 2016-11-17 00:24:23 by ferris ferris
Could be a simple bad solder joint. Sometimes that can cause noise or other problems, and thermal expansion as the machine warms up can make it either better or worse.
added on the 2016-11-17 05:38:13 by psonice psonice
I would bet on an electrolytic capacitor with age weakness. Best to exchange all of them.
added on the 2016-11-17 09:48:46 by Virgill Virgill
Or maybe you should go to some Retro event or demoparty with that thing and let somebody look over it. From RAM to capacitors it could be anything!
added on the 2016-11-17 11:16:35 by Exin Exin
What Virgill said. I'd also check the CIA's (swap them around to see if anything changes).
added on the 2016-11-17 12:23:33 by StingRay StingRay
Caps are pretty rare failures in C64s so far - I've never seen one fail due to bad caps, that's more common with surface mounted stuff. A recap certainly does no harm though, given that they don't exactly get better with age.

Usually it's the PLA, the CIAs or one or more of the memory chips that's the culprit if something's bad inside the machine. That's just statistics though, no substitute for actually checking.
added on the 2016-11-17 12:37:31 by Radiant Radiant
I had also Problems with that. My Problem was solved with another PowerUnit. Try to use a "brick"-PU instead of the "doorstopper"-PU. 1,7 Ampere vs. 1,5 A.
added on the 2016-11-17 13:23:12 by TMA TMA
Likely to be a cap, sounds similar to a CRT problem I had where the picture would be all streaky when powered up from cold, but would pretty much clear after 10-15 minutes once the thing had warmed up. Replacing some of the electrolytic caps on the inputs solved it.
as Radiant said, check the PSU caps. Maybe swap PSUs if you have another, or power it from an ATX PSU or something.
Does the board itself look fine? How does the garbage look like? Is it "appearing" all over the screen or is the cursor being forced to print it? If the cursor prints garbage characters, like mostly arrows and spaces, it can actually be coming from joystick port 1 or the $DC00 area generally (CIA).

The fact that it does get better to me sounds like what psonice said.

I had a Dolphin Dos Rom in a socket which also needed some time to warm up.

If you haven't yet looked at your board, you should. I was shocked myself, when i discovered this while swapping the board for the c64 reloaded:
BB Image
BB Image
(The entire Board looked like this. Probably it was a little hot in their!)
added on the 2016-11-17 21:06:04 by ws ws
@wertstahl: this is normal for a low-cost board produced in that era.

A likely cause of instability with older electronics is the degradation of the electrolytic capacitors. When they dry out, the internal resistance becomes low and they lose their function. You need a capacitor tester/ESR meter to find out which ones, if any, are bad; you can't measure it with a capacitance meter. More often than not, it makes sense to replace them all.

Looking at: https://commons.wikimedia.org/wiki/File:C64_ASSY_NO_250425_motherboard_1984.jpg for reference, replace all the blue capacitors with the equivalent number of microfarads and an equal or higher voltage rating.
added on the 2016-11-18 20:56:25 by trc_wm trc_wm
.. so .. basically what everybody else was saying ..
added on the 2016-11-18 20:58:26 by trc_wm trc_wm
If it actually turns out to be the caps like people (who haven't repaired any C64s themselves I guess?) are suggesting, please let us know. As I said, I haven't heard of a C64 where the caps were the problem so far, but I'm sure they exist, and of course it's going to become more and more of a problem as time progresses.
added on the 2016-11-19 12:04:46 by Radiant Radiant
Given that the problem goes away as the unit warms up, I'm with psonice in that it sounds like a bad solder joint -- or a broken trace. Caps don't go better as they warm up.

I would get some cooling spray (or take a can of duster spray and hold it upside down), let the unit warm up to where it's working, and then systematically start spraying parts of the board. When the error comes back, check the solder joints and traces around that area.
added on the 2016-11-19 12:50:27 by dojoe dojoe
good advice
maybe the guys outside the Matrix are trying to contact you!

good advice
added on the 2016-11-20 02:16:41 by drift drift
First of all, thanks for all of the helpful responses/suggestions! This was interesting :)

Spent some time with this today; here's basically everything I found. Note that as I mentioned in an earlier comment I have tried this machine before with two different PSU's, and that doesn't seem to make much of a difference.

Looked over the board; it looked fairly healthy, but there was corrosion on some of the cap leads and some of the logic chips around the VIC. It didn't look that bad, and I didn't have many replacement caps on hand, so I replaced the 2 of them that looked the worst (one near the VIC and another down near the RAM/ROM area of the board). Didn't help.

I also dug around to see if I could find any shotty traces by eye. I found 5-6 that looked dodgy and resoldered those; again, no dice. I have yet to dry dojoe's coolant spray suggestion though as I didn't have any on hand; that one sounds fun :)

I also tried running the machine without the SID and without the CIA's, and also with the CIA's swapped. I couldn't get it to fail very badly (still a couple garbage chars but not nearly as bad), but then I couldn't get it to do much of anything. :)

I also had a second machine (non-working) that I decided to take apart while I was at it. The problem with _that_ one as it turns out was that the power switch was bad (I hadn't looked into it before after finding out it didn't turn on). I soldered some jumpers to the switch contacts and it booted, but with a very blurry/ghosty video output. However, the logic appeared to work fine for the most part, with some consistent crashes in the middle of the plasma bits in the beginning of Edge of Disgrace.

I swapped around a bunch of the chips in both machines, and what I found was that the CPU's and CIA's were fine, but the PLA and VIC in the second machine were bad. However, the rest of that board was fine, so I ended up throwing the PLA and VIC from the first machine in there. Ran it for a few hours; none of the bugs I had before crept up, so I guess it was something else on the first board.

In any case, I went from one mostly-working machine and one non-working machine to one machine that works quite well, a non-working machine, and some bad chips to have on my desk. :)

I have a feeling the original board is fixable, but other than replacing caps and poking around with a multimeter, I'm not really sure how far I can go effectively myself. Perhaps I'll lug it to a party at some point or try to have someone locally look at it, but at least I have a working machine now.

Thanks again for all of the helpful responses! Lots to try next time I nab a piece of faulty hw :)
added on the 2016-11-20 03:13:47 by ferris ferris
Also forgot to mention, both SID's were fine too (spare woo!)
added on the 2016-11-20 03:16:04 by ferris ferris
So, now there is no excuse to not work on a C64 demo. ;o)
added on the 2016-11-21 09:12:46 by axis^oxy axis^oxy
Congrats! Now, while you have another working Sid, you could go for a dual sid board, like sid2sid. It´s big fun :)
added on the 2016-11-21 09:58:07 by Virgill Virgill


Go to top