pouët.net

Go to bottom

minifmod fails to initialize

category: code [glöplog]
 
Hi,

I’m currently trying to use minifmod. I follow the examples in order to simply play a .xm file, but I can on error on that line :

Code:if (!FSOUND_Init(44100, 0))


FSOUND_Init fails to initialize, and I don’t know why. I use that file, which comes from the ufmod samples :

minifmod example

Any idea? Thanks in advance.
added on the 2013-05-26 14:47:43 by phaazon phaazon
but I got an error*
added on the 2013-05-26 14:50:20 by phaazon phaazon
and it’s not a ufmod sample, but a minifmod. *exhausted*, sorry.
added on the 2013-05-26 14:50:57 by phaazon phaazon
Here you're not enabling any of the loaders:
Code: //#define USEMEMLOAD //#define USEMEMLOADRESOURCE //#define USESAMPLELOADCALLBACK #define USEFMOD

FSound.c:
Code: if (!FSOUND_File_OpenCallback || !FSOUND_File_CloseCallback || !FSOUND_File_ReadCallback || !FSOUND_File_SeekCallback || !FSOUND_File_TellCallback) return FALSE;

Without loaders, FSound will return FALSE immediately.
added on the 2013-05-26 15:01:27 by Gargaj Gargaj
My bad, it falls back to the file loader then. In that case the only way it can return FALSE is when waveOutOpen fails, which is prolly a sound card issue.

Either way, stepdebug into it, that's prolly the easiest way to figure out what's going on.
added on the 2013-05-26 15:04:46 by Gargaj Gargaj
I tried to but the lib seems to be compiled without debug information. I just have the stepping debug of my own code, but nothing after the FSOUND_Init…

What could my card do wrong?
added on the 2013-05-26 15:46:06 by phaazon phaazon
let me guess, you are trying on linux ... with pulseaudio D:
added on the 2013-05-26 16:00:23 by vectory vectory
Nope I just have alsa installed.
added on the 2013-05-26 16:10:23 by phaazon phaazon
welp, fmod.org doesn't host it anymore, but the source is flying around on the nets. so, i guess you are already compiling it with debug symbols :)
added on the 2013-05-26 16:31:29 by vectory vectory
added on the 2013-05-26 16:37:12 by vectory vectory
added on the 2013-05-26 16:37:56 by vectory vectory
I think we have the same linux sources and lib. The problem seems to be asound related… Thank you anyway :)
added on the 2013-05-26 18:57:48 by phaazon phaazon
What about µfmod skypers? Did you try it? A can't remember what format minifmod play, but mebbi you can use it.
added on the 2013-05-27 10:19:08 by Romain337 Romain337
No I didn’t try it yet. Well, I try tonight then.
added on the 2013-05-27 11:35:50 by phaazon phaazon

login

Go to top