pouët.net

Go to bottom

OpenWatcom 1.9-built binaries lock up on 8088 without FPU

category: code [glöplog]
 
For those of you who like to to do the 16-bit DOS thing...
I have been hunting a bug in the OpenWatcom clib the past few days, which made it lock up on an 8088 when no FPU is installed.
I have found that the FPU-detection routine they used was not compatible with 8088, and issued an fwait instruction, which would make the 8088 wait for an 8087 to respond indefinitely.
I have reported the bug and suggested a fix: http://bugzilla.openwatcom.org/show_bug.cgi?id=1161
I have also prepared some fixed clib files here: http://bohemiq.scali.eu.org/Watcomclibc8088.zip

If you're using Watcom, even if you're not actually targeting 8088 w/o FPU, I suggest you use these libraries, because they make the code compatible with these machines, while not having any adverse effects on the other architectures.
added on the 2015-02-27 13:52:19 by Scali Scali
Maybe you can submit it to https://github.com/open-watcom/open-watcom-v2. They seem to be much more reactive there for upstreaming patches.
Quote:
Maybe you can submit it to https://github.com/open-watcom/open-watcom-v2. They seem to be much more reactive there for upstreaming patches.


Yea, I reported it there, and they've implemented a fix: https://github.com/open-watcom/open-watcom-v2/commit/40dfa157a1f419a477a04392473 d188a53495966
added on the 2015-03-04 16:44:45 by Scali Scali
Buy a 486, private dancer :)
added on the 2015-03-05 23:48:42 by superplek superplek

login

Go to top